Contour ROAM durability test

My friend and future riding buddy (we've been resurrecting his G650GL) loaned me his Contour ROAM back in 2013. I used it on the Ulysses on an almost daily basis and got some great videos. I finally mounted it to the XJ over the weekend and yesterday I used it for the first time.  I was traveling from the north to the south side of Indianapolis to do some training when I hit the I65 exit, I noticed something was missing.  That something was the ROAM.   That meant, I had almost 14 miles of 3 lane highway to retrace and search.

After the training session, I rode back to the start of my trip and started looking.  I had the camera mounted in it's waterproof case to help keep it safe from flying road debris since it was mounted fairly low.  Riding down 465, everything on the side of the road looked like it.  Shiny and clear. "There it is! Oh, nope, another bottle. Wait, is that it? Damn." This happened over and over.  I was worried that I lost it while in a middle lane and it got run over or worse, it bounced and hit someone's windshield.

It's lost somewhere along the blue line.

Finally, I tell myself I'm not going to find it and then, what the hell? There it is laying on the stripe between the breakdown lane and the fast lane!  I quickly scan the breakdown lane, merge over and jam on the brakes! Kill the bike, put the side stand down and start the long walk back to find it.  By the time I stopped, it was probably 150 ft behind me.  Thankfully, I got to it before it got hit.  The waterproof case was ground down in places and the door was broken off.  However, the camera was intact! It survived an impact at roughly 65-70 mph and a slide from the middle lane.  Unfortunately, I don't have video of it hitting the ground and sliding through traffic, it stopped recording when it broke free of the mount*.

Way to go Contour, you make one hell of a product! Now, it's secured via camera lanyard looped around my helmet strap.

* Disclaimer:  I was not using the stock supplied double sided tape.  This failure was not the fault of Contour.  It was purely user error.  

No comments: